FFmpeg

Aus Deutsches xmstore Handbuch
Wechseln zu: Navigation, Suche

FFmpeg ist eine freie Software zur Konvertierung und einfachen Bearbeitung von digitalen Video- und Audio-Dateien.
Das Programm wird daher nur benötigt wenn Videos oder Audios im System verwaltet werden sollen (was bei der Image-Edition ausgeschlossen ist).

In diesem Kapitel wird die umfassende Standard-Installation von FFmpeg mit allen benötigten Codecs beschrieben.
Diese Anleitung richtet sich an Eigentümer eines dedizierten Servers.

Inhaltsverzeichnis

Vorraussetzungen

Für die Installation von FFmpeg benötigen Sie

  • Eine GNU/LinuxEin von Linus Torvalds entwickeltes, UNIX-ähnliches Betriebssystem. Wird sehr häufig für den Betrieb von Servern verwendet. Distribution
  • Einen "rootSystemadministrator, Superuser (su), unter Unix/Linux "root" genannt, der immer über alle Berechtigungen verfügt."-SSH Zugang zu Ihrem ServerBezeichnung für einen Computer, der Ressourcen verschiedenster Art anderen Computern im Internet zur Verfügung stellt.
  • 500 MB freien Speicherplatz

Vorbereiten

Loggen Sie sich auf ihrem ServerBezeichnung für einen Computer, der Ressourcen verschiedenster Art anderen Computern im Internet zur Verfügung stellt. als "rootSystemadministrator, Superuser (su), unter Unix/Linux "root" genannt, der immer über alle Berechtigungen verfügt." ein.

Achtung
Einige LinuxEin von Linus Torvalds entwickeltes, UNIX-ähnliches Betriebssystem. Wird sehr häufig für den Betrieb von Servern verwendet.-Distributionen verbieten einen direkten LoginDurch ein Login können Sie sich einen Zugang zu einem System verschaffen. Üblicherweise geschieht dies durch Eingabe eines Benutzernamens und eines Passworts. unter diesem Benutzernamen. Loggen Sie sich anstatt dessen als ein normaler Benutzer ein und verwenden Sie das Kommando
su -
oder
sudo su -
oder
sudo -i
um sich als rootSystemadministrator, Superuser (su), unter Unix/Linux "root" genannt, der immer über alle Berechtigungen verfügt. an zu melden.


Die folgenden Softwarepakete werden zur Installation von FFmpeg benötigt (diese Liste verwendet die Debian-Paketnamen):

  • build-essential
  • gcc
  • tar
  • bzip2

Zusätzlich müssen die folgenden Programme von Quelltext kompiliert werden:

Herunterladen

Um FFmpeg auf den ServerBezeichnung für einen Computer, der Ressourcen verschiedenster Art anderen Computern im Internet zur Verfügung stellt. herunter zu laden gibt es mehrere Möglichkeiten.

1. Git Clone (empfohlen)

Diese Methode läd die neueste Quellversion herunter und erfordert installierte Git-Werkzeuge auf dem ServerBezeichnung für einen Computer, der Ressourcen verschiedenster Art anderen Computern im Internet zur Verfügung stellt., mit folgendem Kommando wird das Git-Archiv geklont:

git clone git://source.ffmpeg.org/ffmpeg.git ffmpeg && cd ffmpeg

Soll FFmpeg später aktualisiert werden, kann dies mit folgendem Befehl im Clone-Verzeichnis getan werden. Danach wird normal mit Kompilieren fortgefahren.

git pull

2. Snapshot Tarball

Bei dieser Methode wird ein Snapshot-Tarball mit folgendem Kommando auf den ServerBezeichnung für einen Computer, der Ressourcen verschiedenster Art anderen Computern im Internet zur Verfügung stellt. geladen und entpackt.

wget http://ffmpeg.org/releases/ffmpeg-snapshot.tar.bz2 && tar -xjf ffmpeg-snapshot.tar.bz2 && cd ffmpeg

Kompilieren

Die folgenden Kommandos kompilieren FFmpeg mit allen verfügbaren Codecs.

./configure --enable-shared --enable-gpl --enable-version3 --enable-nonfree
make
make install
ldconfig /usr/local/lib

Für den Kompiliervorgang wird YASM der Version 1.0 (oder höher) benötigt, diese kann unter http://yasm.tortall.net/Download.html heruntergeladen werden.
Dieser Vorgang kann bis zu einer Stunde dauern.

Optionales H.264 Encoding

Optional kann "libx264" [2] verwendet werden, welches vorinstalliert werden muss. Um eine installierte Version zu benutzen, wird an configure (das erste Kommando der Kompilierbefehle) die Option --enable-libx264 angehangen.

Eine detaillierte Liste der verwendbaren Bibliotheken erhalten Sie mit dem Kommando
./configure --help | grep "\-\-enable\-"

Zur Installation von libx264 wird YASM der Version 1.2 (oder höher) benötigt, diese kann unter http://yasm.tortall.net/Download.html heruntergeladen werden.

Optionales MP3 Encoding

Optional kann der "LAME MP3 Encoder" [3] verwendet werden, welcher vorinstalliert werden muss. Um eine installierte Version zu benutzen, wird an configure (das erste Kommando der Kompilierbefehle) die Option --enable-libmp3lame angehangen.

Eine detaillierte Liste der verwendbaren Bibliotheken erhalten Sie mit dem Kommando
./configure --help | grep "\-\-enable\-"

Optionale Codecs

Mit folgendem Befehl können alle verfügbaren Codecs vor dem Kompilieren abgerufen werden. Die entsprechenden Flags werden einfach an den ./configure-Befehl angefügt.
Durch Hinzufügen von Codecs können weitere Abhängigkeiten zu anderen Programmbibliotheken entstehen, diese müssen für die entsprechenden Codecs entsprechend erfüllt werden!

./configure --help | grep '--enable-'

Fertig

Die Installation von FFmpeg ist nun abgeschlossen. Nun kann die xmstore-Videokonfiguration angepasst werden.

Zusätzliche Informationen

Meine Werkzeuge
Namensräume
Varianten
Aktionen
Navigation
Werkzeuge